Archive

Archive for April, 2013

SharePoint 2013 memory issues

I’ve been working with SharePoint 2013 for a little while now and I’ve noticed some curious issues:

  1. When connecting to a site using SharePoint Designer 2013 I kept getting a message that the site contents could not be loaded. I actually had to stop SharePoint Designer via task manager since I kept getting the message boxes.
  2. When working with the Secure Store Service Application via code I got errors indicating the Secure Store was not started even though it was started according to the Services on Server page in Central Administration.
  3. When working with the Secure Store Service Application via code I got access denied errors on the web service call.
  4. When working with the Secure Store Service Application via code I got access denied errors on the web service call.
  5. When working with the Business Data Connectivity Service Application I got access denied errors on the web service call.

It took me a bit of time, but at the end I found out that these issues arose because of memory issues, or better the lack of available memory. When your SharePoint server uses 95% or more of its memory, web services can no longer be started. The problem I have with my development environment is that it’s a single server setup. SQL Server is running on the same VM and it was slowing eating all my available memory. By setting the maximum server memory I can avoid these issues luckily.

Advertisements
Ben Prins

What I want to remember about SharePoint

blog.frederique.harmsze.nl

my world of work and user experiences

Bram de Jager - Coder, Speaker, Author

Office 365, SharePoint and Azure